p PatchFirst

CVE-2026-43584

CVE-2026-43584 · OpenClaw < 2026.4.10 - Insufficient Environment Variable Denylist in Exec Policy

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.10 contains an insufficient environment variable denylist vulnerability in its exec environment policy that allows operator-supplied overrides of high-risk interpreter startup variables including VIMINIT, EXINIT, LUA_INIT, and HOSTALIASES. Attackers can exploit this by manipulating these environment variables to influence downstream execution behavior or network connectivity.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.10: Affected (semver)
    • 2026.4.10: Not affected (semver)

    Update to 2026.4.10

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.10

    Update to 2026.4.10

Original sources

Check your server →