p PatchFirst

CVE-2026-44992

CVE-2026-44992 · OpenClaw 2026.4.5 through 2026.4.19 - MiniMax API Host Override via Workspace dotenv

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions 2026.4.5 before 2026.4.20 contain an environment variable injection vulnerability allowing workspace dotenv to override MINIMAX_API_HOST. Attackers can redirect credentialed MiniMax API requests to attacker-controlled origins, exposing the MiniMax API key in Authorization headers.

CVSS 4.1 · Medium · EPSS 0.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 2026.4.5, < 2026.4.20: Affected (semver)
    • 2026.4.20: Not affected (semver)

    Update to 2026.4.20

  • openclaw npm

    Affected ranges
    • SEMVER: ≥ 2026.4.5, < 2026.4.20

    Update to 2026.4.20

Original sources

Check your server →