p PatchFirst

CVE-2026-44994

CVE-2026-44994 · OpenClaw < 2026.4.22 - Authentication Bypass in Gateway Control UI Bootstrap Config Endpoint

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.22 contains an authentication bypass vulnerability in the Control UI bootstrap config endpoint that allows unauthenticated attackers to read sensitive configuration fields. Attackers can access the bootstrap config route without a valid Gateway token to expose sensitive bootstrap and config information intended only for authenticated Control UI sessions.

CVSS 6.3 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.22: Affected (semver)
    • 2026.4.22: Not affected (semver)

    Update to 2026.4.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.22

    Update to 2026.4.22

Original sources

Check your server →