p PatchFirst

CVE-2026-45004

CVE-2026-45004 · OpenClaw < 2026.4.23 - Arbitrary Code Execution via setup-api.js in Current Working Directory

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.4.23 contains an arbitrary code execution vulnerability in the bundled plugin setup resolver that loads setup-api.js from process.cwd() during provider setup metadata resolution. Attackers can execute arbitrary JavaScript under the current user account by placing a malicious extensions/<plugin>/setup-api.js file in a repository and convincing a user to run OpenClaw commands from that directory.

CVSS 8.4 · High · EPSS 0.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.4.23: Affected (semver)
    • 2026.4.23: Not affected (semver)

    Update to 2026.4.23

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.4.23

    Update to 2026.4.23

Original sources

Check your server →