CVE-2026-45822
CVE-2026-45822
This page contains facts from public vulnerability sources. Check the original advisory before updating.
decode-uri-component through 0.4.1 is vulnerable to denial of service. The decode() function splits input on '%' producing N tokens and calls decodeComponents(), exhibiting super-linear parsing time: 200 '%ab' tokens takes approximately 0.7s, 700 tokens approximately 6s, and 1400 tokens approximately 33s. An attacker can cause significant CPU consumption and event-loop blocking via crafted input.
CVSS 6.6 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
decode-uri-component
- Versions
- ≥ 0.1.0, < 0.5.0: Affected (semver)
Update to 0.5.0
decode-uri-component npm
- Affected ranges
- SEMVER: < 0.5.0
Update to 0.5.0
node-source-map-resolve Ubuntu:22.04:LTS
- Versions
- 0.6.0+~cs2.7.2-2
- 0.6.0+~cs2.7.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-source-map-resolve Ubuntu:24.04:LTS
- Versions
- 0.6.0+~cs2.7.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-source-map-resolve Ubuntu:25.10
- Versions
- 0.6.0+~cs2.7.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-source-map-resolve Ubuntu:26.10
- Versions
- 0.6.0+~cs2.7.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-source-map-resolve Ubuntu:26.04:LTS
- Versions
- 0.6.0+~cs2.7.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/SamVerschueren/decode-uri-component/blob/00662938dc7c6241547ae8abce7785cc13ffd3f6/index.js
- https://github.com/SamVerschueren/decode-uri-component/commit/fa479dafeede7bedf04e5c89aa78f2a78c664005
- https://www.npmjs.com/package/decode-uri-component
- https://nvd.nist.gov/vuln/detail/CVE-2026-45822