p PatchFirst

CVE-2026-46439

CVE-2026-46439 · compliance-trestle Vulnerable to Remote Code Execution via Recursive Server-Side Template Injection (SSTI)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

compliance-trestle is a tooling platform for managing compliance as code. Versions prior to 3.12.2 and 4.0.3 have a Server-Side Template Injection (SSTI) vulnerability exists in the `trestle author jinja` command. The command recursively evaluates rendered templates, allowing an attacker to achieve arbitrary command execution with privileges of the running process by injecting malicious payloads into data fields (such as SSP documents or Lookup Tables). The vulnerability does not require attacker control of the template itself. Only attacker-controlled input data rendered into a trusted template is required. This distinction is critical: the template author may only intend to render plain text (e.g., `Title: {{ ssp.metadata.title }}`), but because of the recursive parsing, the data field itself becomes executable. The vulnerability is caused by recursive re-compilation and re-rendering of already-rendered output. Versions 3.12.3 and 4.0.3 patch the issue.

CVSS 7.8 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • compliance-trestle

    Versions
    • < 3.12.2: Affected
    • >= 4.0.0, < 4.0.3: Affected

    No fix published

  • compliance-trestle PyPI

    Versions
    • 0.0.2
    • 0.0.3
    • 0.1.0
    • 0.1.1
    • 0.10.0
    • 0.11.0
    • 0.12.0
    • 0.13.0
    • 0.13.1
    • 0.14.0
    • 0.14.1
    • 0.14.2
    • 0.14.3
    • 0.14.4
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.17.0
    • 0.18.0
    • 0.18.1
    • 0.19.0
    • 0.2.0
    • 0.2.1
    • 0.2.2
    • 0.20.0
    • 0.21.0
    • 0.22.0
    • 0.22.1
    • 0.23.0
    • 0.24.0
    • 0.25.0
    • 0.25.1
    • 0.26.0
    • 0.27.0
    • 0.27.1
    • 0.27.2
    • 0.28.0
    • 0.28.1
    • 0.29.0
    • 0.3.0
    • 0.30.0
    • 0.31.0
    • 0.32.0
    • 0.32.1
    • 0.33.0
    • 0.34.0
    • 0.35.0
    • 0.36.0
    • 0.37.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    • 0.6.1
    • 0.6.2
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.8.0
    • 0.8.1
    • 0.9.0
    • 1.0.0rc0
    • 1.0.1
    • 1.0.2
    • 1.1.0
    • 1.2.0
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.2.0
    • 2.2.1
    • 2.3.0
    • 2.3.1
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.6.0
    • 2.6.1
    • 3.0.1
    • 3.1.0
    • 3.10.2
    • 3.10.3
    • 3.10.4
    • 3.11.0
    • 3.12.0
    • 3.12.1
    • 3.2.0
    • 3.3.0
    • 3.4.0
    • 3.5.0
    • 3.6.0
    • 3.7.0
    • 3.8.0
    • 3.8.1
    • 3.9.0
    • 3.9.1
    • 3.9.2
    • 3.9.3
    Affected ranges
    • ECOSYSTEM: < 3.12.2

    Update to 3.12.2

  • compliance-trestle PyPI

    Versions
    • 4.0.0
    • 4.0.1
    • 4.0.2
    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0, < 4.0.3

    Update to 4.0.3

  • compliance-trestle PyPI

    Versions
    • 0.0.2
    • 0.0.3
    • 0.1.0
    • 0.1.1
    • 0.10.0
    • 0.11.0
    • 0.12.0
    • 0.13.0
    • 0.13.1
    • 0.14.0
    • 0.14.1
    • 0.14.2
    • 0.14.3
    • 0.14.4
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.17.0
    • 0.18.0
    • 0.18.1
    • 0.19.0
    • 0.2.0
    • 0.2.1
    • 0.2.2
    • 0.20.0
    • 0.21.0
    • 0.22.0
    • 0.22.1
    • 0.23.0
    • 0.24.0
    • 0.25.0
    • 0.25.1
    • 0.26.0
    • 0.27.0
    • 0.27.1
    • 0.27.2
    • 0.28.0
    • 0.28.1
    • 0.29.0
    • 0.3.0
    • 0.30.0
    • 0.31.0
    • 0.32.0
    • 0.32.1
    • 0.33.0
    • 0.34.0
    • 0.35.0
    • 0.36.0
    • 0.37.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    • 0.6.1
    • 0.6.2
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.8.0
    • 0.8.1
    • 0.9.0
    • 1.0.0rc0
    • 1.0.1
    • 1.0.2
    • 1.1.0
    • 1.2.0
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.2.0
    • 2.2.1
    • 2.3.0
    • 2.3.1
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.6.0
    • 2.6.1
    • 3.0.1
    • 3.1.0
    • 3.10.2
    • 3.10.3
    • 3.10.4
    • 3.11.0
    • 3.12.0
    • 3.12.1
    • 3.2.0
    • 3.3.0
    • 3.4.0
    • 3.5.0
    • 3.6.0
    • 3.7.0
    • 3.8.0
    • 3.8.1
    • 3.9.0
    • 3.9.1
    • 3.9.2
    • 3.9.3
    • 4.0.0
    • 4.0.1
    • 4.0.2
    Affected ranges
    • ECOSYSTEM: < 3.12.2 ∪ ≥ 4.0.0, < 4.0.3

    Update to 3.12.2; Update to 4.0.3

Original sources

Check your server →