CVE-2026-46675
CVE-2026-46675 · UBUNTU-CVE-2026-46675
This page contains facts from public vulnerability sources. Check the original advisory before updating.
[Use-after-free of zlib input in `png_read_end` after incomplete zTXt, iTXt or iCCP decompression]
Fix available
- Published
- Updated
Stack: system
Affected products and versions
libpng1.6 Debian:12
- Versions
- 1.6.39-2
- 1.6.39-2+deb12u1
- 1.6.39-2+deb12u2
- 1.6.39-2+deb12u3
- 1.6.39-2+deb12u4
- 1.6.39-2+deb12u5
- Affected ranges
- ECOSYSTEM: < 1.6.39-2+deb12u6
Update to 1.6.39-2+deb12u6
libpng1.6 Debian:13
- Versions
- 1.6.48-1
- 1.6.48-1+deb13u1
- 1.6.48-1+deb13u2
- 1.6.48-1+deb13u3
- 1.6.48-1+deb13u4
- 1.6.48-1+deb13u5
- Affected ranges
- ECOSYSTEM: < 1.6.48-1+deb13u6
Update to 1.6.48-1+deb13u6
libpng1.6 Debian:14
- Versions
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- 1.6.52-1
- 1.6.53-1
- 1.6.54-1
- 1.6.55-1
- 1.6.56-1
- 1.6.57-1
- 1.6.58-1
- Affected ranges
- ECOSYSTEM: < 1.6.59-1
Update to 1.6.59-1
libpng1.6 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- 1.6.20-2ubuntu0.1~esm2
- 1.6.20-2ubuntu0.1~esm3
- 1.6.20-2ubuntu0.1~esm4
- Affected ranges
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm5
Update to 1.6.20-2ubuntu0.1~esm5
libpng1.6 Ubuntu:Pro:18.04:LTS
- Versions
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- 1.6.34-1ubuntu0.18.04.2+esm1
- 1.6.34-1ubuntu0.18.04.2+esm2
- 1.6.34-1ubuntu0.18.04.2+esm3
- Affected ranges
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm4
Update to 1.6.34-1ubuntu0.18.04.2+esm4
libpng1.6 Ubuntu:Pro:20.04:LTS
- Versions
- 1.6.37-1
- 1.6.37-2
- 1.6.37-2ubuntu0.1~esm1
- 1.6.37-2ubuntu0.1~esm2
- 1.6.37-2ubuntu0.1~esm3
- Affected ranges
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm4
Update to 1.6.37-2ubuntu0.1~esm4
libpng1.6 Ubuntu:22.04:LTS
- Versions
- 1.6.37-3build4
- 1.6.37-3build5
- 1.6.37-3ubuntu0.1
- 1.6.37-3ubuntu0.3
- 1.6.37-3ubuntu0.4
- 1.6.37-3ubuntu0.5
- 1.6.37-3ubuntu0.6
- Affected ranges
- ECOSYSTEM: < 1.6.37-3ubuntu0.7
Update to 1.6.37-3ubuntu0.7
libpng1.6 Ubuntu:24.04:LTS
- Versions
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- 1.6.43-5ubuntu0.3
- 1.6.43-5ubuntu0.4
- 1.6.43-5ubuntu0.5
- 1.6.43-5ubuntu0.6
- Affected ranges
- ECOSYSTEM: < 1.6.43-5ubuntu0.7
Update to 1.6.43-5ubuntu0.7
libpng1.6 Ubuntu:26.04:LTS
- Versions
- 1.6.50-1
- 1.6.51-1
- 1.6.53-1
- 1.6.54-1
- 1.6.55-1
- 1.6.56-1
- 1.6.57-1
- Affected ranges
- ECOSYSTEM: < 1.6.57-1ubuntu0.1
Update to 1.6.57-1ubuntu0.1
Original sources
- https://ubuntu.com/security/CVE-2026-46675
- https://www.cve.org/CVERecord?id=CVE-2026-46675
- https://github.com/pnggroup/libpng/security/advisories/GHSA-qvg3-h654-xq3j
- https://github.com/pnggroup/libpng/issues/855
- https://ubuntu.com/security/notices/USN-8899-1
- https://osv.dev/vulnerability/UBUNTU-CVE-2026-46675