p PatchFirst

CVE-2026-47137

CVE-2026-47137 · vm2: GHSA-8hg8-63c5-gwmx patch bypass: nesting:true without explicit require still allows full RCE

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, the fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. This issue has been patched in version 3.11.4.

CVSS 10.0 · Critical · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • vm2

    Versions
    • < 3.11.4: Affected

    No fix published

  • vm2 npm

    Affected ranges
    • SEMVER: < 3.11.4

    Update to 3.11.4

Original sources

Check your server →