p PatchFirst

CVE-2026-4810

CVE-2026-4810 · Remote Code Execution in Google Agent Development Kit (ADK)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A Code Injection and Missing Authentication vulnerability in Google Agent Development Kit (ADK) versions 1.7.0 (and 2.0.0a1) through 1.28.1 (and 2.0.0a2) on Python (OSS), Cloud Run, and GKE allows an unauthenticated remote attacker to execute arbitrary code on the server hosting the ADK instance. This vulnerability was patched in versions 1.28.1 and 2.0.0a2. Customers need to redeploy the upgraded ADK to their production environments. In addition, if they are running ADK Web locally, they also need to upgrade their local instance.

CVSS 9.3 · Critical · EPSS 1.8% · Public exploit · Fix available

Published
Updated

Stack: python

Affected products and versions

  • agent development kit (adk)

    Versions
    • ≥ 1.7.0, < 1.28.1: Affected (custom)
    • ≥ 2.0.0a1, < 2.0.0a2: Affected (custom)

    Update to 1.28.1; Update to 2.0.0a2

  • google-adk PyPI

    Versions
    • 1.10.0
    • 1.11.0
    • 1.12.0
    • 1.13.0
    • 1.14.0
    • 1.14.1
    • 1.15.0
    • 1.15.1
    • 1.16.0
    • 1.17.0
    • 1.18.0
    • 1.19.0
    • 1.20.0
    • 1.21.0
    • 1.22.0
    • 1.22.1
    • 1.23.0
    • 1.24.0
    • 1.24.1
    • 1.25.0
    • 1.25.1
    • 1.26.0
    • 1.27.0
    • 1.27.1
    • 1.27.2
    • 1.27.3
    • 1.27.4
    • 1.27.5
    • 1.28.0
    • 1.7.0
    • 1.8.0
    • 1.9.0
    Affected ranges
    • ECOSYSTEM: ≥ 1.7.0, < 1.28.1

    Update to 1.28.1

  • google-adk PyPI

    Versions
    • 2.0.0a1
    Affected ranges
    • ECOSYSTEM: ≥ 2.0.0a1, < 2.0.0a2

    Update to 2.0.0a2

  • google-adk PyPI

    Versions
    • 1.10.0
    • 1.11.0
    • 1.12.0
    • 1.13.0
    • 1.14.0
    • 1.14.1
    • 1.15.0
    • 1.15.1
    • 1.16.0
    • 1.17.0
    • 1.18.0
    • 1.19.0
    • 1.20.0
    • 1.21.0
    • 1.22.0
    • 1.22.1
    • 1.23.0
    • 1.24.0
    • 1.24.1
    • 1.25.0
    • 1.25.1
    • 1.26.0
    • 1.27.0
    • 1.27.1
    • 1.27.2
    • 1.27.3
    • 1.27.4
    • 1.27.5
    • 1.28.0
    • 1.7.0
    • 1.8.0
    • 1.9.0
    • 2.0.0a1
    Affected ranges
    • ECOSYSTEM: ≥ 1.7.0, < 1.28.1 ∪ ≥ 2.0.0a1, < 2.0.0a2

    Update to 1.28.1; Update to 2.0.0a2

Original sources

Check your server →