p PatchFirst

CVE-2026-49142

CVE-2026-49142 · OpenEMR Before 8.5.0 SQL Injection via form_icd_codes[]

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenEMR before 8.5.0 contains an authenticated SQL injection vulnerability in the Syndromic Surveillance module that allows users with Clinician-level privileges to read and modify arbitrary database contents by submitting crafted values in the form_icd_codes[] POST parameter to the syndromicsurveillance/index endpoint. Attackers can inject an unquoted numeric IN() clause and UNION DISTINCT SELECT statement using hex-encoded literals to abuse MySQL extractvalue() for error-based exfiltration of bcrypt password hashes and execute stacked queries that reset passwords, resulting in full administrative account takeover.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Affected products and versions

  • openemr

    Versions
    • ≥ 0, < 8.5.0: Affected (semver)

    Update to 8.5.0

Original sources

Check your server →