p PatchFirst

CVE-2026-53816

CVE-2026-53816 · OpenClaw < 2026.5.18 - Exec Lifecycle Event Forgery via Paired Node

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.5.18 contains an insufficient provenance validation vulnerability in node event handling that allows paired nodes to forge exec lifecycle events without system.run authorization. A malicious or compromised paired node can send crafted node.event messages to the gateway, steering target sessions into exec-event paths that expose capabilities the reduced node surface should not provide.

CVSS 8.6 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.5.18: Affected (semver)
    • 2026.5.18: Not affected (semver)

    Update to 2026.5.18

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.5.18

    Update to 2026.5.18

Original sources

Check your server →