p PatchFirst

CVE-2026-53817

CVE-2026-53817 · OpenClaw < 2026.5.22 - Control UI Locality Spoofing in Device Pairing

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.5.22 contains a locality validation vulnerability in Control UI pairing that allows attackers with network access to spoof locality information and obtain durable admin-capable device tokens. Attackers can exploit insufficient locality-derived trust validation to convert temporary shared access into persistent administrative credentials that survive token rotation.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.5.22: Affected (semver)
    • 2026.5.22: Not affected (semver)

    Update to 2026.5.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.5.22

    Update to 2026.5.22

Original sources

Check your server →