p PatchFirst

CVE-2026-53821

CVE-2026-53821 · OpenClaw < 2026.5.18 - Scope Elevation in trusted-proxy Control UI WebSocket

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.5.18 accepts WebSocket client-declared operator scopes before binding to server-approved pairing or trusted-proxy authorization baseline. Unpaired or restricted trusted-proxy Control UI clients can obtain cached operator.admin authority on live WebSocket connections to execute admin-gated Gateway RPCs.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.5.18: Affected (semver)
    • 2026.5.18: Not affected (semver)

    Update to 2026.5.18

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.5.18

    Update to 2026.5.18

Original sources

Check your server →