p PatchFirst

CVE-2026-53831

CVE-2026-53831 · OpenClaw < 2026.5.18 - Arbitrary File Read via Shell Expansion in system.run Safe-bin Allowlist

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.5.18 contains a policy enforcement vulnerability in system.run safe-bin allowlist validation that allows shell expansion to modify command interpretation on POSIX nodes. Authenticated operators can exploit shell metacharacters in approved commands to read unintended node-local files and expose sensitive configuration data.

CVSS 7.6 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.5.18: Affected (semver)
    • 2026.5.18: Not affected (semver)

    Update to 2026.5.18

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.5.18

    Update to 2026.5.18

Original sources

Check your server →