p PatchFirst

CVE-2026-56340

CVE-2026-56340 · vLLM - Denial of Service via Unvalidated Multimodal Embeddings

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

CVSS 8.7 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • ≥ 0.10.2, < 0.13.0: Affected (semver)
    • 0.13.0: Not affected (semver)

    Update to 0.13.0

  • vllm PyPI

    Versions
    • 0.10.2
    • 0.11.0
    • 0.11.1
    • 0.11.2
    • 0.12.0
    Affected ranges
    • ECOSYSTEM: ≥ 0.10.2, < 0.13.0

    Update to 0.13.0

Original sources

Check your server →