CVE-2026-56372
CVE-2026-56372 · ImageMagick - Heap Buffer Overflow Read via Unrecognized Magnify Method
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ImageMagick before 7.1.2-19 contains a heap buffer overflow vulnerability in the magnify operation that allows attackers to read out of bounds memory. An unrecognized magnify:method value triggers an out of bounds read, potentially exposing sensitive information or causing denial of service.
CVSS 4.8 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
imagemagick
- Versions
- ≥ 0, < 7.1.2-19: Affected (semver)
- 7.1.2-19: Not affected (semver)
Update to 7.1.2-19
imagemagick Debian:13
- Versions
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.43+dfsg1-1+deb13u1
- 8:7.1.1.43+dfsg1-1+deb13u10
- 8:7.1.1.43+dfsg1-1+deb13u11
- 8:7.1.1.43+dfsg1-1+deb13u2
- 8:7.1.1.43+dfsg1-1+deb13u3
- 8:7.1.1.43+dfsg1-1+deb13u4
- 8:7.1.1.43+dfsg1-1+deb13u5
- 8:7.1.1.43+dfsg1-1+deb13u6
- 8:7.1.1.43+dfsg1-1+deb13u7
- 8:7.1.1.43+dfsg1-1+deb13u8
- 8:7.1.1.43+dfsg1-1+deb13u9
- Affected ranges
- ECOSYSTEM: < 8:7.1.1.43+dfsg1-1+deb13u12
Update to 8:7.1.1.43+dfsg1-1+deb13u12
imagemagick Debian:14
- Versions
- 8:7.1.1.43+dfsg1-1
- 8:7.1.1.46+dfsg1-1
- 8:7.1.1.47+dfsg1-1
- 8:7.1.1.47+dfsg1-2
- 8:7.1.2.1+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.15+dfsg1-2
- 8:7.1.2.16+dfsg1-1
- 8:7.1.2.18+dfsg1-1
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.7+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- Affected ranges
- ECOSYSTEM: < 8:7.1.2.19+dfsg1-1
Update to 8:7.1.2.19+dfsg1-1
imagemagick Ubuntu:Pro:26.04:LTS
- Versions
- 8:7.1.2.3+dfsg1-1
- 8:7.1.2.8+dfsg1-1
- 8:7.1.2.12+dfsg1-1
- 8:7.1.2.13+dfsg1-1
- 8:7.1.2.15+dfsg1-1
- 8:7.1.2.16+dfsg1-1
- 8:7.1.2.18+dfsg1-1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm1
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm2
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm3
- 8:7.1.2.18+dfsg1-1ubuntu0.1~esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published