CVE-2026-57211
CVE-2026-57211 · RabbitMQ: UNC SSRF affecting the management UI on Windows
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RabbitMQ is a messaging and streaming broker. Prior to 4.1.11 and 4.2.6 on Windows, the RabbitMQ management plugin static file handler rabbit_mgmt_wm_static can pass URL-encoded backslashes to erl_prim_loader:read_file_info before path validation when multiple management extension plugins are enabled, causing outbound DNS and SMB requests to attacker-controlled UNC paths. This issue is fixed in versions 4.1.11 and 4.2.6.
CVSS 6.5 · Medium · EPSS 0.6%
- Published
- Updated
Affected products and versions
rabbitmq
- Versions
- >= 4.2.0, < 4.2.6: Affected
- >= 4.1.0, < 4.1.11: Affected
No fix published
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versions
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- 3.5.7-1ubuntu0.16.04.4+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Versions
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- 3.6.10-1ubuntu0.5+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Versions
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- 3.8.3-0ubuntu0.3+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:22.04:LTS
- Versions
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- 3.9.13-1ubuntu0.22.04.2
- 3.9.27-0ubuntu0.1
- 3.9.27-0ubuntu0.2
- 3.9.27-0ubuntu0.5
- 3.9.27-0ubuntu0.6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:24.04:LTS
- Versions
- 3.12.1-1
- 3.12.1-1ubuntu1
- 3.12.1-1ubuntu1.2
- 3.12.1-1ubuntu1.4
- 3.12.1-1ubuntu1.6
- 3.12.1-1ubuntu1.7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:26.10
- Versions
- 4.0.5-10ubuntu5
- 4.3.2-4ubuntu2
- 4.3.2-4ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:26.04:LTS
- Versions
- 4.0.5-8ubuntu2
- 4.0.5-10ubuntu1
- 4.0.5-10ubuntu2
- 4.0.5-10ubuntu3
- 4.0.5-10ubuntu4
- 4.0.5-10ubuntu5
- 4.0.5-10ubuntu5.1
- 4.0.5-10ubuntu5.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-7v84-m3g5-vxq6
- https://github.com/rabbitmq/rabbitmq-server/pull/15803
- https://github.com/rabbitmq/rabbitmq-server/commit/39c3a8e9c71da0403d8dfc13f700e60c936e3682
- https://github.com/rabbitmq/rabbitmq-server/commit/6730797f6a34b4e8308cea60adf1243857e70204
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://nvd.nist.gov/vuln/detail/CVE-2026-57211