CVE-2026-58471
CVE-2026-58471 · GNU Wget 1.25.0 Heap Buffer Overflow via convert_fname() in url.c
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GNU Wget through 1.25.0, fixed in commit c2640fe, contains a heap buffer overflow vulnerability in the convert_fname() function within src/url.c that allows remote attackers to trigger memory corruption through a server-supplied filename requiring character set conversion. When the output buffer is too small during iconv E2BIG reallocation, the reallocation logic miscalculates the remaining space, leading to a heap buffer overflow that can be exploited via a maliciously crafted server response.
CVSS 6.0 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wget
- Versions
- ≥ 0, ≤ 1.25.0: Affected (semver)
- c2640fe5171c59f87c58dc9fcb195b2d18b010ee: Not affected (git)
No fix published
wget Debian:12
- Versions
- 1.21.3-1
- 1.21.3-1+deb12u1
- 1.21.4-1
- 1.24.5-1
- 1.24.5-2
- 1.25.0-1
- 1.25.0-2
- 1.25.0-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wget Debian:13
- Versions
- 1.25.0-2
- 1.25.0-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wget Debian:14
- Versions
- 1.25.0-2
- 1.25.0-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wget Ubuntu:Pro:18.04:LTS
- Versions
- 1.19.1-3ubuntu1
- 1.19.1-3ubuntu1.1
- 1.19.2-1ubuntu1
- 1.19.3-2ubuntu1
- 1.19.4-1ubuntu2
- 1.19.4-1ubuntu2.1
- 1.19.4-1ubuntu2.2
- 1.19.4-1ubuntu2.2+esm1
- Affected ranges
- ECOSYSTEM: < 1.19.4-1ubuntu2.2+esm3
Update to 1.19.4-1ubuntu2.2+esm3
wget Ubuntu:Pro:20.04:LTS
- Versions
- 1.20.3-1ubuntu1
- 1.20.3-1ubuntu2
- 1.20.3-1ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 1.20.3-1ubuntu2.1+esm2
Update to 1.20.3-1ubuntu2.1+esm2
wget Ubuntu:22.04:LTS
- Versions
- 1.21-1ubuntu3
- 1.21-1ubuntu4
- 1.21-1ubuntu5
- 1.21.2-2ubuntu1
- 1.21.2-2ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.21.2-2ubuntu1.3
Update to 1.21.2-2ubuntu1.3
wget Ubuntu:24.04:LTS
- Versions
- 1.21.3-1ubuntu1
- 1.21.4-1ubuntu1
- 1.21.4-1ubuntu2
- 1.21.4-1ubuntu3
- 1.21.4-1ubuntu4
- 1.21.4-1ubuntu4.1
- Affected ranges
- ECOSYSTEM: < 1.21.4-1ubuntu4.3
Update to 1.21.4-1ubuntu4.3
wget Ubuntu:25.10
- Versions
- 1.24.5-2ubuntu1
- 1.25.0-2ubuntu1
- 1.25.0-2ubuntu2
- 1.25.0-2ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wget Ubuntu:26.04:LTS
- Versions
- 1.25.0-2ubuntu3
- 1.25.0-2ubuntu4
- Affected ranges
- ECOSYSTEM: < 1.25.0-2ubuntu4.2
Update to 1.25.0-2ubuntu4.2