p PatchFirst

CVE-2026-58587

CVE-2026-58587 · Drupal Canvas - Moderately critical - Improper validation - SA-CONTRIB-2026-065

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal Canvas allows Cross-Site Scripting (XSS). This issue affects Drupal Canvas versions: from 0.0.0 to 1.4.2, from 1.5.0 to 1.5.2, from 1.6.0 to 1.6.1, from 1.7.0 to 1.7.1.

CVSS 6.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • drupal canvas

    Versions
    • ≥ 0.0.0, < 1.4.2: Affected (semver)
    • ≥ 1.5.0, < 1.5.2: Affected (semver)
    • ≥ 1.6.0, < 1.6.1: Affected (semver)
    • ≥ 1.7.0, < 1.7.1: Affected (semver)

    Update to 1.4.2; Update to 1.5.2; Update to 1.6.1; Update to 1.7.1

  • drupal/canvas Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 1.4.2
    • ECOSYSTEM: ≥ 1.5.0, < 1.5.2
    • ECOSYSTEM: ≥ 1.6.0, < 1.6.1
    • ECOSYSTEM: ≥ 1.7.0, < 1.7.1

    Update to 1.4.2; Update to 1.5.2; Update to 1.6.1; Update to 1.7.1

Original sources

Check your server →