CVE-2026-59965
CVE-2026-59965 · @jhb.software/payload-alt-text-plugin: Alt Text Endpoint Authorization Bypass via Payload Local API `overrideAccess` Omission
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Payload Plugins is a collection of plugins designed to enhance Payload CMS. In 0.7.0, @jhb.software/payload-alt-text-plugin exposes POST /api/alt-text-plugin/generate and POST /api/alt-text-plugin/bulk with a default guard that accepts any authenticated user, while alt-text/src/endpoints/generateAltText.ts and alt-text/src/endpoints/bulkGenerateAltTexts.ts call req.payload.findByID and req.payload.update without overrideAccess: false. Payload therefore defaults overrideAccess to true and skips the target collection's read and update access functions. An authenticated low-privilege user can supply id, collection, locale, and update values to read arbitrary protected upload documents and overwrite their alt and keywords fields, even when the collection permits those operations only to administrators. A control Local API call with overrideAccess: false is denied, confirming that the plugin endpoint bypasses otherwise effective collection rules. This vulnerability is fixed in 0.8.0.
CVSS 7.1 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
payload-plugins
- Versions
- < 0.8.0: Affected
No fix published
payload-alt-text-plugin
- Versions
- < 0.8.0: Affected
No fix published
@jhb.software/payload-alt-text-plugin npm
- Affected ranges
- SEMVER: < 0.8.0
Update to 0.8.0
Original sources
- https://github.com/jhb-software/payload-plugins/security/advisories/GHSA-4qpv-39hg-f7fx
- https://github.com/jhb-software/payload-plugins/pull/159
- https://github.com/jhb-software/payload-plugins/commit/e39634868ce13a414e2981e219befc58101654d3
- https://github.com/jhb-software/payload-plugins/releases/tag/[email protected]
- https://nvd.nist.gov/vuln/detail/CVE-2026-59965