CVE-2026-59984
CVE-2026-59984 · OpenEXR: Scratch buffer overflow decoding B44-compressed InputFile on ILP32
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. OpenEXR versions 3.1.0 through 3.2.10, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13 are vulnerable on ILP32 builds to an out-of-bounds write. When a crafted B44-compressed scanline EXR causes the logical scratch size to truncate before allocation and uncompress_b44_impl() writes using the attacker-controlled channel width, allowing denial of service and memory corruption. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.
CVSS 5.5 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
openexr
- Versions
- >= 3.1.0, < 3.2.11: Affected
- >= 3.3.0, < 3.3.13: Affected
- >= 3.4.0, < 3.4.14: Affected
No fix published
openexr Debian:12
- Versions
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Debian:13
- Versions
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Debian:14
- Versions
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Affected ranges
- ECOSYSTEM: < 3.4.14-0.1
Update to 3.4.14-0.1
openexr Ubuntu:Pro:16.04:LTS
- Versions
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- 2.2.0-10ubuntu2.1
- 2.2.0-10ubuntu2.2
- 2.2.0-10ubuntu2.3
- 2.2.0-10ubuntu2.4
- 2.2.0-10ubuntu2.6
- 2.2.0-10ubuntu2.6+esm1
- 2.2.0-10ubuntu2.6+esm2
- 2.2.0-10ubuntu2.6+esm3
- 2.2.0-10ubuntu2.6+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:18.04:LTS
- Versions
- 2.2.0-11ubuntu1
- 2.2.0-11.1ubuntu1
- 2.2.0-11.1ubuntu1.1
- 2.2.0-11.1ubuntu1.2
- 2.2.0-11.1ubuntu1.3
- 2.2.0-11.1ubuntu1.4
- 2.2.0-11.1ubuntu1.6
- 2.2.0-11.1ubuntu1.7
- 2.2.0-11.1ubuntu1.8
- 2.2.0-11.1ubuntu1.9
- 2.2.0-11.1ubuntu1.9+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:20.04:LTS
- Versions
- 2.2.1-4.1ubuntu1
- 2.3.0-6
- 2.3.0-6build1
- 2.3.0-6ubuntu0.1
- 2.3.0-6ubuntu0.2
- 2.3.0-6ubuntu0.3
- 2.3.0-6ubuntu0.5
- 2.3.0-6ubuntu0.5+esm1
- 2.3.0-6ubuntu0.5+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:22.04:LTS
- Versions
- 2.5.4-2
- 2.5.7-1
- 2.5.7-1ubuntu0.1~esm1
- 2.5.7-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:24.04:LTS
- Versions
- 3.1.5-5.1
- 3.1.5-5.1build1
- 3.1.5-5.1build2
- 3.1.5-5.1build3
- 3.1.5-5.1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:26.10
- Versions
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
openexr Ubuntu:Pro:26.04:LTS
- Versions
- 3.1.13-2
- 3.1.13-2build1
- 3.1.13-2ubuntu0.26.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-92pq-9qv4-g68q
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.2.11
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.13
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.14
- https://nvd.nist.gov/vuln/detail/CVE-2026-59984