CVE-2026-63388
CVE-2026-63388 · Libevent: Heap out-of-bounds write in bufferevent_socket_set_conn_address_ reachable via AF_UNIX accept
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has a heap out-of-bounds write in bufferevent_sock.c when bufferevent_socket_set_conn_address_ copies a kernel-supplied AF_UNIX peer address into bufferevent_private.conn_address. Release builds compiled with NDEBUG disable the EVUTIL_ASSERT length guard, and the evhttp accept path can pass a 110-byte sockaddr from accept() into the 28-byte field. An unauthenticated local peer able to connect to an AF_UNIX listener can overwrite the adjacent dns_request pointer and heap data, causing memory corruption with confidentiality, integrity, and availability impact. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.
CVSS 8.4 · High · EPSS 0.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libevent
- Versions
- < 2.1.13: Affected
- >= 2.2.0-alpha, < 2.2.2-alpha: Affected
No fix published
libevent Debian:12
- Versions
- 2.1.12-stable-8
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-8+deb12u1
Update to 2.1.12-stable-8+deb12u1
libevent Debian:13
- Versions
- 2.1.12-stable-10
- Affected ranges
- ECOSYSTEM: < 2.1.13-stable-1~deb13u1
Update to 2.1.13-stable-1~deb13u1
libevent Debian:14
- Versions
- 2.1.12-stable-10
- 2.1.13-stable-1~deb13u1
- Affected ranges
- ECOSYSTEM: < 2.1.13-stable-1
Update to 2.1.13-stable-1
libevent Ubuntu:Pro:18.04:LTS
- Versions
- 2.1.8-stable-4
- 2.1.8-stable-4build1
- 2.1.8-stable-4ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 2.1.8-stable-4ubuntu0.1~esm2
Update to 2.1.8-stable-4ubuntu0.1~esm2
libevent Ubuntu:Pro:20.04:LTS
- Versions
- 2.1.8-stable-4build1
- 2.1.11-stable-1~exp0
- 2.1.11-stable-1
- 2.1.11-stable-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 2.1.11-stable-1ubuntu0.1~esm2
Update to 2.1.11-stable-1ubuntu0.1~esm2
libevent Ubuntu:22.04:LTS
- Versions
- 2.1.12-stable-1
- 2.1.12-stable-1build1
- 2.1.12-stable-1build2
- 2.1.12-stable-1build3
- 2.1.12-stable-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-1ubuntu0.2
Update to 2.1.12-stable-1ubuntu0.2
libevent Ubuntu:24.04:LTS
- Versions
- 2.1.12-stable-9
- 2.1.12-stable-9ubuntu2
- 2.1.12-stable-9ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-9ubuntu2.2
Update to 2.1.12-stable-9ubuntu2.2
libevent Ubuntu:26.04:LTS
- Versions
- 2.1.12-stable-10build1
- 2.1.12-stable-10build2
- 2.1.12-stable-10ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 2.1.12-stable-10ubuntu0.2
Update to 2.1.12-stable-10ubuntu0.2
Original sources
- https://github.com/libevent/libevent/security/advisories/GHSA-cvq5-vrvr-j338
- https://github.com/libevent/libevent/commit/52057cb33d0c20c0a0453fbabe6c0c96854931b9
- https://github.com/libevent/libevent/commit/ef38f926e9cd1f082416c6fff13587bc1f431d72
- https://github.com/libevent/libevent/releases/tag/release-2.1.13-stable
- https://github.com/libevent/libevent/releases/tag/release-2.2.2-alpha
- https://nvd.nist.gov/vuln/detail/CVE-2026-63388