CVE-2026-63626
CVE-2026-63626 · Mongoose: ppp_handle_ipv6cp() uses attacker-controlled length without bounds check — OOB read and heap overflow (PPP/PPPoE, MG_ENABLE_IPV6)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Mongoose is an embedded web server and network library. Prior to 7.23, ppp_handle_ipv6cp() in src/l2_ppp.c trusts the 16-bit IPv6CP len field without checking it against the received payload size. On a PPP or PPPoE link using MG_ENABLE_TCPIP and MG_ENABLE_IPV6, an unauthenticated adjacent peer can complete the required LCP exchange and send a short Configure-Request with an oversized length, causing ppp_tx_frame() to read beyond recv_queue.buf and write beyond tx.buf. The same length misuse can also expose adjacent heap bytes in a reply or hang the event loop through find_opt(). This issue is fixed in version 7.23.
CVSS 8.8 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongoose
- Versions
- < 7.23: Affected
No fix published
mongoose Debian:14
- Versions
- 7.21+ds-1
- 7.21+ds-1~bpo13+1
- 7.21+ds-2
- 7.22+ds-1
- 7.22+ds-1~bpo13+1
- 7.23+ds-1~bpo13+1
- Affected ranges
- ECOSYSTEM: < 7.23+ds-1
Update to 7.23+ds-1
mongoose Ubuntu:26.10
- Versions
- 7.21+ds-1
- 7.21+ds-2
- 7.22+ds-1
- 7.23+ds-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published