CVE-2026-64638
CVE-2026-64638
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress is vulnerable to a pre-auth reflected XSS vulnerability on the login screen. Via a specially crafted malicious third-party website hosted by an attacker, it is possible for this to be escalated to an RCE vulnerability with conditions outside of the attackers control. This requires successful social engineering of and explicit interaction by the target victim. This issue affects all versions of WordPress. Version 7.0.3 has been released, containing a fix for the vulnerability, and as a courtesy to users on older branches the fix has been backported to all branches back to 4.7. Discovered and responsibly disclosed by [the team at pwn.ai](https://pwn.ai/).
CVSS 8.9 · High · EPSS 0.9% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress
- Versions
- ≥ 0, < 7.0.3: Not affected (semver)
No fix published
wordpress Debian:12
- Versions
- 6.1.1+dfsg1-1
- 6.1.6+dfsg1-0+deb12u1
- 6.1.9+dfsg1-0+deb12u1
- 6.2+dfsg1-1
- 6.2.1+dfsg1-1
- 6.2.2+dfsg1-1
- 6.3+dfsg1-1
- 6.3.1+dfsg1-1
- 6.3.2+dfsg1-1
- 6.4.1+dfsg1-1
- 6.4.1+dfsg1-1.1
- 6.4.2+dfsg1-1
- 6.4.3+dfsg1-1
- 6.5+dfsg1-1
- 6.5.2+dfsg1-1
- 6.5.3+dfsg1-1
- 6.5.5+dfsg1-1
- 6.6.1+dfsg1-1
- 6.7.2+dfsg1-1
- 6.7.2+dfsg1-1.1
- 6.8.1+dfsg1-1
- 6.8.3+dfsg1-1
- 6.9+dfsg1-1
- 6.9.4+dfsg1-1
- 7.0+dfsg1-1
- 7.0.2+dfsg1-1
- 7.0.3+dfsg1-1
- 7.1+dfsg1-1
- 7.1.1+dfsg1-1
- 7.1.2+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Debian:13
- Versions
- 6.8.1+dfsg1-1
- 6.8.3+dfsg1-0+deb13u1
- 6.8.3+dfsg1-1
- 6.8.6+dfsg1-0+deb13u1
- Affected ranges
- ECOSYSTEM: < 6.8.7+dfsg1-0+deb13u1
Update to 6.8.7+dfsg1-0+deb13u1
wordpress Debian:14
- Versions
- 6.8.1+dfsg1-1
- 6.8.3+dfsg1-1
- 6.9+dfsg1-1
- 6.9.4+dfsg1-1
- 7.0+dfsg1-1
- 7.0.2+dfsg1-1
- Affected ranges
- ECOSYSTEM: < 7.0.3+dfsg1-1
Update to 7.0.3+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:24.04:LTS
- Versions
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.10
- Versions
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.04:LTS
- Versions
- 6.7.2+dfsg1-1.1ubuntu1
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published