p PatchFirst

CVE-2026-65593

CVE-2026-65593 · n8n before 1.123.64, 2.29.8, and 2.30.1 SSRF via Dynamic Node Parameters

This page contains facts from public vulnerability sources. Check the original advisory before updating.

n8n versions before 1.123.64, 2.29.8, and 2.30.1 contain a server-side request forgery vulnerability in the dynamic-node-parameters endpoints that lack authorization scopes. Authenticated attackers can supply absolute URLs in routing configuration to override baseURL restrictions and make the n8n server issue HTTP requests to arbitrary internal targets when SSRF protection is disabled.

CVSS 6.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n8n

    Versions
    • ≥ 0, < 1.123.64: Affected (semver)
    • 1.123.64: Not affected (semver)

    Update to 1.123.64

  • n8n

    Versions
    • ≥ 0, < 2.30.1: Affected (semver)
    • 2.30.1: Not affected (semver)

    Update to 2.30.1

  • n8n

    Versions
    • ≥ 0, < 2.29.8: Affected (semver)
    • 2.29.8: Not affected (semver)

    Update to 2.29.8

  • n8n npm

    Affected ranges
    • SEMVER: < 1.123.64

    Update to 1.123.64

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 2.30.0, < 2.30.1

    Update to 2.30.1

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 2.0.0-rc.0, < 2.29.8

    Update to 2.29.8

Original sources

Check your server →