p PatchFirst

CVE-2026-65596

CVE-2026-65596 · n8n before 1.123.64 Credential Exfiltration via GraphQL Node

This page contains facts from public vulnerability sources. Check the original advisory before updating.

n8n before 1.123.64, 2.29.8, and 2.30.1 fails to enforce the "Allowed HTTP Request Domains" restriction on HTTP-based credentials (Header Auth, Basic Auth, Query Auth, OAuth) in the GraphQL node, unlike the HTTP Request node. An authenticated user able to create or edit workflows can point the node's endpoint at a server they control and exfiltrate restricted credentials. Only instances where a credential has "Allowed HTTP Request Domains" configured and is usable by non-owner users are affected.

CVSS 5.1 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n8n

    Versions
    • ≥ 0, < 1.123.64: Affected (semver)
    • 1.123.64: Not affected (semver)

    Update to 1.123.64

  • n8n

    Versions
    • ≥ 0, < 2.30.1: Affected (semver)
    • 2.30.1: Not affected (semver)

    Update to 2.30.1

  • n8n

    Versions
    • ≥ 0, < 2.29.8: Affected (semver)
    • 2.29.8: Not affected (semver)

    Update to 2.29.8

  • n8n npm

    Affected ranges
    • SEMVER: < 1.123.64

    Update to 1.123.64

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 2.30.0, < 2.30.1

    Update to 2.30.1

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 2.0.0, < 2.29.8

    Update to 2.29.8

Original sources

Check your server →