p PatchFirst

CVE-2026-65597

CVE-2026-65597 · n8n before 1.123.64 DOM-Based XSS via Unsandboxed iframe

This page contains facts from public vulnerability sources. Check the original advisory before updating.

n8n before 1.123.64, 2.x before 2.29.8, and before 2.30.1 contains a DOM-based cross-site scripting vulnerability in the HTML preview, which renders execution output into an iframe srcdoc without the sandbox attribute. A sanitizer bypass allows injected script to execute same-origin as the editor. When a victim opens the preview, the script can call authenticated APIs using the victim's session. An account with global:member privileges can exploit the issue.

CVSS 8.2 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n8n

    Versions
    • ≥ 0, < 1.123.64: Affected (semver)
    • 1.123.64: Not affected (semver)

    Update to 1.123.64

  • n8n

    Versions
    • ≥ 0, < 2.30.1: Affected (semver)
    • 2.30.1: Not affected (semver)

    Update to 2.30.1

  • n8n

    Versions
    • ≥ 0, < 2.29.8: Affected (semver)
    • 2.29.8: Not affected (semver)

    Update to 2.29.8

  • n8n npm

    Affected ranges
    • SEMVER: < 1.123.64

    Update to 1.123.64

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 2.30.0, < 2.30.1

    Update to 2.30.1

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 2.0.0-rc.0, < 2.29.8

    Update to 2.29.8

Original sources

Check your server →