CVE-2026-67241
CVE-2026-67241 · RabbitMQ: AMQP 1.0 management exchange.declare skips alternate-exchange permission check
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.9 and 4.3.3, AMQP 1.0 management exchange.declare skips alternate-exchange permission check. pUT /exchanges/:name (lines 192-240) checks only configure on the declared exchange and passes XArgs straight to rabbitexchange:declare/7. It omits the checkreadpermitted(X) + checkwritepermitted(AE) that rabbitchannel.erl:2540-2548 enforces for the alternate-exchange argument on the AMQP 0-9-1 path. The same file already implements the analogous DLX check for queues (lines 708-719), confirming this is a missing-check bug rather than intentional A user with only configure on exchange X can route X's unroutable messages into an alternate exchange they have no write permission AMQP 1.0 enabled (default in RabbitMQ 4.x) Attacker has configure on at least one exchange but lacks write on the target. This issue is fixed in versions 4.2.9 and 4.3.3.
CVSS 4.8 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
rabbitmq
- Versions
- >= 4.2.0, < 4.2.9: Affected
- >= 4.3.0, < 4.3.3: Affected
No fix published
rabbitmq-server Debian:14
- Versions
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- Affected ranges
- ECOSYSTEM: < 4.3.6-1
Update to 4.3.6-1
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versions
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- 3.5.7-1ubuntu0.16.04.4+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Versions
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- 3.6.10-1ubuntu0.5+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Versions
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- 3.8.3-0ubuntu0.3+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:22.04:LTS
- Versions
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- 3.9.13-1ubuntu0.22.04.2
- 3.9.27-0ubuntu0.1
- 3.9.27-0ubuntu0.2
- 3.9.27-0ubuntu0.5
- 3.9.27-0ubuntu0.6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:24.04:LTS
- Versions
- 3.12.1-1
- 3.12.1-1ubuntu1
- 3.12.1-1ubuntu1.2
- 3.12.1-1ubuntu1.4
- 3.12.1-1ubuntu1.6
- 3.12.1-1ubuntu1.7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:26.10
- Versions
- 4.0.5-10ubuntu5
- 4.3.2-4ubuntu2
- 4.3.2-4ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:26.04:LTS
- Versions
- 4.0.5-8ubuntu2
- 4.0.5-10ubuntu1
- 4.0.5-10ubuntu2
- 4.0.5-10ubuntu3
- 4.0.5-10ubuntu4
- 4.0.5-10ubuntu5
- 4.0.5-10ubuntu5.1
- 4.0.5-10ubuntu5.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-rg2g-289m-xhhw
- https://github.com/rabbitmq/rabbitmq-server/commit/18eac8d547b4382bf830c621b20a35932dd1cfa5
- https://github.com/rabbitmq/rabbitmq-server/commit/56005e7cebffc478ef397573de24aff1167e7cda
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3
- https://nvd.nist.gov/vuln/detail/CVE-2026-67241