CVE-2026-6732
CVE-2026-6732 · Libxml2: libxml2: denial of service via crafted xsd-validated document
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in libxml2. This vulnerability occurs when the library processes a specially crafted XML Schema Definition (XSD) validated document that includes an internal entity reference. An attacker could exploit this by providing a malicious document, leading to a type confusion error that causes the application to crash. This results in a denial of service (DoS), making the affected system or application unavailable.
CVSS 6.5 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
red hat hardened images
- Versions
- ≥ 2.15.3-0.1.hum1: Not affected (rpm)
No fix published
red hat enterprise linux 10
No fix published
red hat enterprise linux 6
No fix published
red hat enterprise linux 7
No fix published
red hat enterprise linux 8
No fix published
red hat enterprise linux 9
No fix published
red hat jboss core services
No fix published
red hat openshift container platform 4
No fix published
libxml2 Debian:14
- Versions
- 2.12.7+dfsg+really2.9.14-2.1
- 2.13.1+dfsg-0exp1
- 2.13.3+dfsg-0exp1
- 2.13.3+dfsg-0exp2
- 2.14.1+dfsg-0exp1
- 2.14.2+dfsg-0exp1
- 2.14.3+dfsg-0exp1
- 2.14.3+dfsg-0exp2
- 2.14.3+dfsg-0exp3
- 2.14.4+dfsg-0exp1
- 2.14.5+dfsg-0.1
- 2.14.5+dfsg-0.2
- 2.14.5+dfsg-0exp1
- 2.14.5+dfsg-0exp2
- 2.14.6+dfsg-0.1
- 2.15.0+dfsg-0.1
- 2.15.0+dfsg-0.2
- 2.15.0+dfsg-0.3
- 2.15.1+dfsg-0.1
- 2.15.1+dfsg-0.2
- 2.15.1+dfsg-0.3
- 2.15.1+dfsg-0.4
- 2.15.1+dfsg-0.5
- 2.15.1+dfsg-1
- 2.15.1+dfsg-2
- 2.15.2+dfsg-0.1
- Affected ranges
- ECOSYSTEM: < 2.15.3+dfsg-1
Update to 2.15.3+dfsg-1
libxml2 Ubuntu:25.10
- Versions
- 2.12.7+dfsg+really2.9.14-0.4
- 2.12.7+dfsg+really2.9.14-0.4ubuntu0.1
- 2.12.7+dfsg+really2.9.14-1
- 2.14.3+dfsg-0exp1
- 2.14.3+dfsg-0exp2
- 2.14.3+dfsg-0exp3
- 2.14.4+dfsg-0exp1
- 2.14.5+dfsg-0exp1
- 2.14.5+dfsg-0exp2
- 2.14.5+dfsg-0.1
- 2.14.5+dfsg-0.2
- 2.14.5+dfsg-0.2ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 2.14.5+dfsg-0.2ubuntu0.2
Update to 2.14.5+dfsg-0.2ubuntu0.2
libxml2 Ubuntu:26.04:LTS
- Versions
- 2.14.5+dfsg-0.2
- 2.14.5+dfsg-0.2build1
- 2.15.1+dfsg-0.3
- 2.15.1+dfsg-0.4
- 2.15.1+dfsg-1
- 2.15.1+dfsg-2
- 2.15.1+dfsg-2ubuntu1
- 2.15.1+dfsg-2ubuntu2
- 2.15.2+dfsg-0.1
- Affected ranges
- ECOSYSTEM: < 2.15.2+dfsg-0.1ubuntu0.1
Update to 2.15.2+dfsg-0.1ubuntu0.1
Original sources
- https://access.redhat.com/errata/RHSA-2026:11503
- https://access.redhat.com/security/cve/CVE-2026-6732
- https://bugzilla.redhat.com/show_bug.cgi?id=2461300
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/1097
- https://gitlab.gnome.org/GNOME/libxml2/-/merge_requests/411
- https://nvd.nist.gov/vuln/detail/CVE-2026-6732