CVE-2026-69304
CVE-2026-69304 · ASP.NET Core Denial of Service Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper handling of highly compressed data (data amplification) in ASP.NET Core allows an unauthorized attacker to deny service over a network.
CVSS 5.9 · Medium · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
.net 10.0
- Versions
- ≥ 10.0.0, < 10.0.12: Affected (custom)
Update to 10.0.12
.net 8.0
- Versions
- ≥ 8.0.0, < 8.0.31: Affected (custom)
Update to 8.0.31
.net 9.0
- Versions
- ≥ 9.0.0, < 9.0.20: Affected (custom)
Update to 9.0.20
asp.net core 10.0
- Versions
- ≥ 10.0, < 10.0.12: Affected (custom)
Update to 10.0.12
asp.net core 11.0
- Versions
- ≥ 11.0, < 11.0 RC1: Affected (custom)
No fix published
asp.net core 8.0
- Versions
- ≥ 8.0, < 8.0.31: Affected (custom)
Update to 8.0.31
asp.net core 9.0
- Versions
- ≥ 9.0, < 9.0.20: Affected (custom)
Update to 9.0.20
microsoft visual studio 2022 version 17.14
- Versions
- ≥ 17.14.0, < 17.14.40: Affected (custom)
Update to 17.14.40
microsoft visual studio 2026 version 18.9
- Versions
- ≥ 18.9.0, < 18.9.3: Affected (custom)
Update to 18.9.3
dotnet7 Ubuntu:22.04:LTS
- Versions
- 7.0.105-0ubuntu1~22.04.1
- 7.0.107-0ubuntu1~22.04.1
- 7.0.108-0ubuntu1~22.04.1
- 7.0.109-0ubuntu1~22.04.1
- 7.0.110-0ubuntu1~22.04.1
- 7.0.111-0ubuntu1~22.04.1
- 7.0.112-0ubuntu1~22.04.1
- 7.0.113-0ubuntu1~22.04.1
- 7.0.114-0ubuntu1~22.04.1
- 7.0.115-0ubuntu1~22.04.1
- 7.0.116-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.2
- 7.0.119-0ubuntu1~22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published