CVE-2026-72763
CVE-2026-72763 · n8n before 1.123.67 Credential Exfiltration via Sub-Workflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
n8n before 1.123.67, 2.31.5, and 2.32.1 validates credential-access only for a node's top-level credentials and not for credentials referenced inside an Execute Sub-workflow node's inline workflow JSON. A member with Editor access to a shared workflow (when workflow sharing is enabled) who knows a target credential's ID can reference that credential in the inline JSON; it passes save-time and runtime validation and resolves in the parent workflow's project context, allowing the attacker to use or exfiltrate credentials they are not permitted to access.
CVSS 7.2 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
n8n
- Versions
- ≥ 0, < 1.123.67: Affected (semver)
- 1.123.67: Not affected (semver)
Update to 1.123.67
n8n
- Versions
- ≥ 0, < 2.32.1: Affected (semver)
- 2.32.1: Not affected (semver)
Update to 2.32.1
n8n
- Versions
- ≥ 0, < 2.31.5: Affected (semver)
- 2.31.5: Not affected (semver)
Update to 2.31.5
n8n npm
- Affected ranges
- SEMVER: < 1.123.67
Update to 1.123.67
n8n npm
- Affected ranges
- SEMVER: ≥ 2.32.0, < 2.32.1
Update to 2.32.1
n8n npm
- Affected ranges
- SEMVER: ≥ 2.0.0-rc.0, < 2.31.5
Update to 2.31.5