CVE-2026-72767
CVE-2026-72767 · n8n before 1.123.67 Remote Code Execution via Git node
This page contains facts from public vulnerability sources. Check the original advisory before updating.
n8n before 1.123.67, 2.x before 2.31.5, and 2.32.x before 2.32.1 contain a remote code execution vulnerability in the Git node. Authenticated users with rights to create and execute workflows can stage a crafted local repository that causes git to run hooks under default git security settings, executing arbitrary commands as the n8n process user. Both self-hosted and cloud instances are affected.
CVSS 8.7 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
n8n
- Versions
- ≥ 0, < 1.123.67: Affected (semver)
- 1.123.67: Not affected (semver)
Update to 1.123.67
n8n
- Versions
- ≥ 0, < 2.32.1: Affected (semver)
- 2.32.1: Not affected (semver)
Update to 2.32.1
n8n
- Versions
- ≥ 0, < 2.31.5: Affected (semver)
- 2.31.5: Not affected (semver)
Update to 2.31.5
n8n npm
- Affected ranges
- SEMVER: < 1.123.67
Update to 1.123.67
n8n npm
- Affected ranges
- SEMVER: ≥ 2.32.0, < 2.32.1
Update to 2.32.1
n8n npm
- Affected ranges
- SEMVER: ≥ 2.0.0-rc.0, < 2.31.5
Update to 2.31.5