CVE-2026-75911
CVE-2026-75911 · CodeWhale before 0.8.64 Remote Code Execution via allow_shell
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.
CVSS 8.5 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
codewhale
- Versions
- ≥ 0.8.6, < 0.8.41: Affected (semver)
- 0.8.41: Not affected (semver)
Update to 0.8.41
codewhale
- Versions
- ≥ 0.8.41, < 0.8.64: Affected (semver)
- 0.8.64: Not affected (semver)
Update to 0.8.64
deepseek-tui crates.io
- Affected ranges
- SEMVER: ≥ 0.8.6, ≤ 0.8.41
No fix published
deepseek-tui npm
- Affected ranges
- SEMVER: ≥ 0.8.6, < 0.8.41
Update to 0.8.41
codewhale-tui crates.io
- Affected ranges
- SEMVER: ≥ 0.8.41, < 0.8.64
Update to 0.8.64
codewhale npm
- Affected ranges
- SEMVER: ≥ 0.8.41, < 0.8.64
Update to 0.8.64