CVE-2026-75912
CVE-2026-75912 · CodeWhale before 0.8.64 Argument Injection via git_blame
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CodeWhale versions before 0.8.64 contain an argument injection vulnerability in the git_blame tool that allows attackers to read arbitrary files by injecting git options into the unvalidated rev parameter. Attackers can supply rev values like --contents=/path/to/file to exfiltrate sensitive files such as SSH keys and credentials through the tool output returned to the model.
CVSS 8.3 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
codewhale
- Versions
- ≥ 0.3.27, < 0.8.41: Affected (semver)
- 0.8.41: Not affected (semver)
Update to 0.8.41
codewhale
- Versions
- ≥ 0.8.41, < 0.8.64: Affected (semver)
- 0.8.64: Not affected (semver)
Update to 0.8.64
deepseek-tui crates.io
- Affected ranges
- SEMVER: ≥ 0.3.27, ≤ 0.8.41
No fix published
deepseek-tui npm
- Affected ranges
- SEMVER: ≥ 0.3.27, < 0.8.41
Update to 0.8.41
codewhale-tui crates.io
- Affected ranges
- SEMVER: ≥ 0.8.41, < 0.8.64
Update to 0.8.64
codewhale npm
- Affected ranges
- SEMVER: ≥ 0.8.41, < 0.8.64
Update to 0.8.64