p PatchFirst

CVE-2026-75915

CVE-2026-75915 · CodeWhale before 0.8.64 Environment Variable Leak via js_execution

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.

CVSS 8.7 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • codewhale

    Versions
    • ≥ 0.8.32, < 0.8.41: Affected (semver)
    • 0.8.41: Not affected (semver)

    Update to 0.8.41

  • codewhale

    Versions
    • ≥ 0.8.41, < 0.8.64: Affected (semver)
    • 0.8.64: Not affected (semver)

    Update to 0.8.64

  • deepseek-tui crates.io

    Affected ranges
    • SEMVER: ≥ 0.8.32, ≤ 0.8.41

    No fix published

  • deepseek-tui npm

    Affected ranges
    • SEMVER: ≥ 0.8.32, < 0.8.41

    Update to 0.8.41

  • codewhale-tui crates.io

    Affected ranges
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Update to 0.8.64

  • codewhale npm

    Affected ranges
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Update to 0.8.64

Original sources

Check your server →