CVE-2026-76228
CVE-2026-76228 · Renovate before 42.68.5 Remote Code Execution via Gradle Wrapper
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Renovate versions >=32.124.0 and before 42.68.5 (and Mend renovate-ce/renovate-ee before 13.3.0) contain a command injection vulnerability in Gradle Wrapper artifact handling. When Renovate processes Gradle Wrapper updates, it invokes a wrapper update command via a shell (e.g. /bin/sh -c ... ./gradlew :wrapper --gradle-distribution-url <value>). If an attacker supplies a malicious gradle-wrapper.properties whose distributionUrl contains shell command substitution syntax such as $(...), the shell evaluates it before Gradle parses the URL, resulting in arbitrary command execution in the Renovate runtime. Exploitation requires the attacker to introduce the malicious file into a repository that Renovate scans; the issue occurs even when allowScripts is disabled.
CVSS 8.4 · High · EPSS 1.0% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
renovate
- Versions
- ≥ 32.124.0, < 42.68.5: Affected (semver)
- 42.68.5: Not affected (semver)
Update to 42.68.5
renovate-ce
- Versions
- ≥ 0, < 13.3.0: Affected (semver)
- 13.3.0: Not affected (semver)
Update to 13.3.0
renovate-ee-server
- Versions
- ≥ 0, < 13.3.0: Affected (semver)
- 13.3.0: Not affected (semver)
Update to 13.3.0
renovate-ee-worker
- Versions
- ≥ 0, < 13.3.0: Affected (semver)
- 13.3.0: Not affected (semver)
Update to 13.3.0
renovate npm
- Affected ranges
- SEMVER: ≥ 32.124.0, < 42.68.5
Update to 42.68.5