CVE-2026-76890
CVE-2026-76890 · Expired Pointer Dereference in Wireshark
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Crash in sharkd in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
CVSS 3.1 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wireshark
- Versions
- ≥ 4.6.0, < 4.6.8: Affected (semver)
- ≥ 4.4.0, < 4.4.18: Affected (semver)
Update to 4.4.18; Update to 4.6.8
wireshark Debian:12
- Versions
- 4.0.10-1
- 4.0.11-1
- 4.0.11-1~deb12u1
- 4.0.17-0+deb12u1
- 4.0.17-0+deb12u2
- 4.0.17-0+deb12u3
- 4.0.3-1
- 4.0.5-1~exp1
- 4.0.6-1
- 4.0.6-1~deb12u1
- 4.0.6-1~exp1
- 4.0.7-1
- 4.0.8-1
- 4.2.0-1
- 4.2.0-1~exp0
- 4.2.0~rc3-1~exp1
- 4.2.2-1
- 4.2.2-1.1
- 4.2.2-1.1~exp1
- 4.2.4-1
- 4.2.5-1
- 4.2.5-2
- 4.2.6-1
- 4.4.0-0exp1
- 4.4.0-0exp2
- 4.4.0-1
- 4.4.1-1
- 4.4.2-1
- 4.4.3-1
- 4.4.4-1
- 4.4.5-1
- 4.4.6-1
- 4.4.6-2
- 4.4.7-0exp1
- 4.4.7-1
- 4.4.8-0exp1
- 4.4.9-1
- 4.6.0-0exp1
- 4.6.0-1
- 4.6.0~rc1-0exp1
- 4.6.0~rc1-0exp2
- 4.6.1-1
- 4.6.1-2
- 4.6.2-1
- 4.6.2-3
- 4.6.3-1
- 4.6.4-1
- 4.6.5-1
- 4.6.6-1
- 4.6.6-2
- 4.6.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Debian:13
- Versions
- 4.4.13-0+deb13u1
- 4.4.14-0+deb13u1
- 4.4.15-0+deb13u1
- 4.4.16-0+deb13u1
- 4.4.7-1
- 4.4.8-0exp1
- 4.4.9-1
- Affected ranges
- ECOSYSTEM: < 4.4.18-0+deb13u1
Update to 4.4.18-0+deb13u1
wireshark Debian:14
- Versions
- 4.4.7-1
- 4.4.8-0exp1
- 4.4.9-1
- 4.6.0-0exp1
- 4.6.0-1
- 4.6.0~rc1-0exp1
- 4.6.0~rc1-0exp2
- 4.6.1-1
- 4.6.1-2
- 4.6.2-1
- 4.6.2-3
- 4.6.3-1
- 4.6.4-1
- 4.6.5-1
- 4.6.6-1
- 4.6.6-2
- Affected ranges
- ECOSYSTEM: < 4.6.9-1
Update to 4.6.9-1
wireshark Ubuntu:Pro:14.04:LTS
- Versions
- 1.10.2-1
- 1.10.3-1
- 1.10.5-1ubuntu1
- 1.10.5-2
- 1.10.6-1
- 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
- 2.6.3-1~ubuntu14.04.1
- 2.6.4-2~ubuntu14.04.1
- 2.6.5-1~ubuntu14.04.1
- 2.6.6-1~ubuntu14.04.0
- 2.6.8-1~ubuntu14.04.0~esm1
- 2.6.10-1~ubuntu14.04.0~esm1
- 2.6.10-1~ubuntu14.04.0~esm2
- 2.6.10-1~ubuntu14.04.0~esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Ubuntu:Pro:16.04:LTS
- Versions
- 1.12.7+g7fc8978-1
- 1.12.8+g5b6e543-2
- 2.0.1+g59ea380-3build1
- 2.0.2+ga16e22e-1
- 2.2.6+g32dac6a-2ubuntu0.16.04
- 2.6.3-1~ubuntu16.04.1
- 2.6.4-2~ubuntu16.04.0
- 2.6.5-1~ubuntu16.04.0
- 2.6.6-1~ubuntu16.04.0
- 2.6.8-1~ubuntu16.04.0
- 2.6.10-1~ubuntu16.04.0
- 2.6.10-1~ubuntu16.04.0+esm1
- 2.6.10-1~ubuntu16.04.0+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Ubuntu:Pro:18.04:LTS
- Versions
- 2.4.2-1
- 2.4.3-1
- 2.4.4-1
- 2.4.5-1
- 2.6.3-1~ubuntu18.04.1
- 2.6.4-2~ubuntu18.04.0
- 2.6.5-1~ubuntu18.04.0
- 2.6.6-1~ubuntu18.04.0
- 2.6.8-1~ubuntu18.04.0
- 2.6.10-1~ubuntu18.04.0
- 2.6.10-1~ubuntu18.04.0+esm1
- 2.6.10-1~ubuntu18.04.0+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Ubuntu:Pro:20.04:LTS
- Versions
- 3.0.5-1
- 3.0.7-1
- 3.2.1-1
- 3.2.2-1
- 3.2.3-1
- 3.2.3-1ubuntu0.1~esm1
- 3.2.3-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Ubuntu:Pro:22.04:LTS
- Versions
- 3.4.7-1~exp1
- 3.4.9-1
- 3.6.2-1ubuntu1
- 3.6.2-2
- 3.6.2-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Ubuntu:24.04:LTS
- Versions
- 4.0.8-1
- 4.0.10-1
- 4.0.11-1
- 4.2.0-1
- 4.2.2-1
- 4.2.2-1.1build1
- 4.2.2-1.1build2
- 4.2.2-1.1build3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Ubuntu:26.10
- Versions
- 4.6.4-1
- 4.6.6-1
- 4.6.6-2
- 4.6.6-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wireshark Ubuntu:26.04:LTS
- Versions
- 4.4.7-1
- 4.6.0-1
- 4.6.1-2
- 4.6.2-3
- 4.6.3-1
- 4.6.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published