p PatchFirst

CVE-2026-7700

CVE-2026-7700 · langflow-ai langflow LambdaFilterComponent lambda_filter.py eval code injection

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A weakness has been identified in langflow-ai langflow up to 1.10.2. This affects the function eval of the file src/lfx/src/lfx/components/llm_operations/lambda_filter.py of the component LambdaFilterComponent. Executing a manipulation can lead to code injection. The attack may be performed from remote. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

CVSS 5.3 · Medium · EPSS 0.3% · Public exploit · Fix available

Published
Updated

Stack: python

Affected products and versions

  • langflow

    Versions
    • 1.10.0: Affected
    • 1.10.1: Affected
    • 1.10.2: Affected

    No fix published

  • langflow PyPI

    Versions
    • 1.10.0
    • 1.10.0rc0
    • 1.10.1
    • 1.10.1rc0
    • 1.10.1rc3
    • 1.10.2
    • 1.10.2rc4
    • 1.10.3rc0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.5.0
    • 1.5.0.post1
    • 1.5.0.post2
    • 1.5.1
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.6.7
    • 1.6.8
    • 1.6.9
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8.0
    • 1.8.0rc0
    • 1.8.0rc1
    • 1.8.0rc2
    • 1.8.0rc3
    • 1.8.0rc4
    • 1.8.0rc5
    • 1.8.0rc6
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.8.3rc0
    • 1.8.4
    • 1.9.0
    • 1.9.1
    • 1.9.2
    • 1.9.3
    • 1.9.3rc0
    • 1.9.4
    • 1.9.5
    • 1.9.6
    • 1.9.6rc0
    Affected ranges
    • ECOSYSTEM: ≥ 1.3.0, < 1.10.3

    Update to 1.10.3

Original sources

Check your server →