CVE-2026-7816
CVE-2026-7816 · pgAdmin 4: OS command injection in Import/Export query export via psql metacommand breakout
This page contains facts from public vulnerability sources. Check the original advisory before updating.
OS command injection (CWE-78) vulnerability in pgAdmin 4 Import/Export query export. User-supplied input was interpolated directly into a psql \copy metacommand template without sanitization. An authenticated user could inject ") TO PROGRAM 'cmd'" to break out of the \copy (...) context and achieve arbitrary command execution on the pgAdmin server, or ") TO '/path'" for arbitrary file write. Additional fields (format, on_error, log_verbosity) were also raw-interpolated and exploitable. Fix adds a parens-balance parser modeled on psql's strtokx tokenizer, allow-lists format/on_error/log_verbosity, rejects null bytes in the query, and tightens type and gating checks. This issue affects pgAdmin 4: before 9.15.
CVSS 8.7 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
pgadmin 4
- Versions
- ≥ 9.4, < 9.15: Affected (custom)
Update to 9.15
pgadmin4 PyPI
- Versions
- 4.20
- 4.22
- 4.23
- 4.24
- 4.25
- 4.26
- 4.27
- 4.28
- 4.29
- 4.30
- 5.0
- 5.1
- 5.2
- 5.3
- 5.4
- 5.5
- 5.6
- 5.7
- 6.10
- 6.11
- 6.12
- 6.13
- 6.14
- 6.15
- 6.16
- 6.17
- 6.18
- 6.19
- 6.2
- 6.20
- 6.21
- 6.3
- 6.4
- 6.5
- 6.6
- 6.7
- 6.8
- 6.9
- 7.0
- 7.1
- 7.2
- 7.3
- 7.4
- 7.5
- 7.6
- 7.7
- 7.8
- 8.0
- 8.1
- 8.10
- 8.11
- 8.12
- 8.13
- 8.14
- 8.2
- 8.3
- 8.4
- 8.5
- 8.6
- 8.7
- 8.8
- 8.9
- 9.0
- 9.1
- 9.10
- 9.11
- 9.12
- 9.13
- 9.14
- 9.2
- 9.3
- 9.4
- 9.5
- 9.6
- 9.7
- 9.8
- 9.9
- Affected ranges
- ECOSYSTEM: < 9.15
Update to 9.15