CVE-2026-80067
CVE-2026-80067 · MasterStudy LMS WordPress Plugin < 3.7.50 Path Traversal via stm_lms_step Parameter
This page contains facts from public vulnerability sources. Check the original advisory before updating.
MasterStudy LMS plugin for WordPress before 3.7.50 contains a path traversal vulnerability that allows authenticated Subscriber-level users to import arbitrary WXR XML files by supplying directory traversal sequences in the stm_lms_step parameter passed to the stm_lms_import_sample_data AJAX action, which lacks capability checks and nonce verification. Attackers can traverse the file system to reference a reachable WXR file and have the handler publish its contained posts under their identity, enabling publication of attacker-chosen post type, title, content, and metadata.
CVSS 5.3 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
masterstudy lms wordpress plugin
- Versions
- ≥ 0, < 3.7.50: Affected (semver)
Update to 3.7.50
Original sources
- https://docs.stylemixthemes.com/masterstudy-lms/changelog-free-version
- https://wordpress.org/plugins/masterstudy-lms-learning-management-system
- https://www.vulncheck.com/advisories/masterstudy-lms-wordpress-plugin-path-traversal-via-stm-lms-step-parameter
- https://nvd.nist.gov/vuln/detail/CVE-2026-80067