CVE-2026-82858
CVE-2026-82858 · @hulumi/drift before 1.3.2 Unsafe Execute Plan Acceptance
This page contains facts from public vulnerability sources. Check the original advisory before updating.
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
CVSS 9.3 · Critical · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
drift
- Versions
- ≥ 0, < 1.3.2: Affected (semver)
- 1.3.2: Not affected (semver)
Update to 1.3.2
@hulumi/drift npm
- Affected ranges
- SEMVER: < 1.3.2
Update to 1.3.2