CVE-2026-82864
CVE-2026-82864 · pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pdfme pdf-lib versions before 5.5.10 contain an unbounded buffer growth vulnerability in the DecodeStream.ensureBuffer() method that allows attackers to cause denial of service by supplying a crafted PDF with a FlateDecode stream containing a decompression bomb. Attackers can upload a small compressed PDF that decompresses to hundreds of megabytes, exhausting memory and crashing the Node.js process or freezing browser tabs during PDF parsing.
CVSS 7.1 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
pdf-lib
- Versions
- ≥ 0, < 5.5.10: Affected (semver)
- 5.5.10: Not affected (semver)
Update to 5.5.10
@pdfme/pdf-lib npm
- Affected ranges
- SEMVER: < 5.5.10
Update to 5.5.10