CVE-2026-83608
CVE-2026-83608 · xmldom: DocType `name` Injection Bypasses requireWellFormed
This page contains facts from public vulnerability sources. Check the original advisory before updating.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, the DOCUMENT_TYPE_NODE branch in lib/dom.js validates publicId, systemId, and internalSubset under requireWellFormed: true but emits DocumentType.name verbatim. A name containing > or whitespace can terminate the <!DOCTYPE ...> declaration and inject sibling markup; the value can be supplied through createDocumentType() on the 0.8.x and unscoped lines or through a direct DocumentType.name property write on every affected line. The default path and legacy creation-time behavior remain permissive, while the vulnerable strict path fails to enforce an XML Name. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.
CVSS 8.7 · High · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
xmldom
- Versions
- <= 0.6.0: Affected
No fix published
xmldom
- Versions
- >= 0.9.0, < 0.9.12: Affected
- >= 0.7.0, < 0.8.15: Affected
No fix published
node-xmldom Debian:12
- Versions
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Debian:13
- Versions
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Debian:14
- Versions
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: < 0.9.12-1
Update to 0.9.12-1
@xmldom/xmldom npm
- Affected ranges
- SEMVER: ≥ 0.7.0, < 0.8.15
Update to 0.8.15
@xmldom/xmldom npm
- Affected ranges
- SEMVER: ≥ 0.9.0, < 0.9.12
Update to 0.9.12
xmldom npm
- Affected ranges
- SEMVER: ≤ 0.6.0
No fix published
node-xmldom Ubuntu:20.04:LTS
- Versions
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:22.04:LTS
- Versions
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:24.04:LTS
- Versions
- 0.8.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.10
- Versions
- 0.9.8-2
- 0.9.10-2
- 0.9.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.04:LTS
- Versions
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/xmldom/xmldom/security/advisories/GHSA-27p8-2357-5qqv
- https://github.com/xmldom/xmldom/pull/1071
- https://github.com/xmldom/xmldom/pull/1072
- https://github.com/xmldom/xmldom/commit/57aec90ac57b4408ae7c5d1746bf2a693b5ed90e
- https://github.com/xmldom/xmldom/commit/85f12eb4d14b44de33216cfb72b50af4d24e9fdd
- https://github.com/xmldom/xmldom/releases/tag/0.8.15
- https://github.com/xmldom/xmldom/releases/tag/0.9.12
- https://nvd.nist.gov/vuln/detail/CVE-2026-83608