CVE-2026-83610
CVE-2026-83610 · xmldom: XML fragment injection via invalid EntityReference.nodeName during requireWellFormed serialization
This page contains facts from public vulnerability sources. Check the original advisory before updating.
xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, Document.createEntityReference(name) accepts an invalid name and the ENTITY_REFERENCE_NODE serializer emits the resulting nodeName directly in &name; form. Directly serializing the node or fragment with XMLSerializer.serializeToString() and requireWellFormed: true can therefore break the entity-reference boundary and produce attacker-controlled XML markup when reparsed. The parser does not ordinarily create these nodes, and element-child insertion is rejected, so exploitation requires an application to create and directly serialize an EntityReference. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.
CVSS 6.3 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
xmldom
- Versions
- <= 0.6.0: Affected
No fix published
xmldom
- Versions
- >= 0.7.0, < 0.8.15: Affected
- >= 0.9.0, < 0.9.12: Affected
No fix published
node-xmldom Debian:12
- Versions
- 0.8.6-1
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.5-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Debian:13
- Versions
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.12-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Debian:14
- Versions
- 0.9.10-1
- 0.9.10-2
- 0.9.11-1
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- 0.9.9-1
- Affected ranges
- ECOSYSTEM: < 0.9.12-1
Update to 0.9.12-1
@xmldom/xmldom npm
- Affected ranges
- SEMVER: ≥ 0.7.0, < 0.8.15
Update to 0.8.15
@xmldom/xmldom npm
- Affected ranges
- SEMVER: ≥ 0.9.0, < 0.9.12
Update to 0.9.12
xmldom npm
- Affected ranges
- SEMVER: ≤ 0.6.0
No fix published
node-xmldom Ubuntu:20.04:LTS
- Versions
- 0.1.27+ds-1
- 0.1.27+ds-1+deb10u2build0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:22.04:LTS
- Versions
- 0.5.0-1
- 0.7.3-1
- 0.7.5-1
- 0.7.5-1ubuntu0.22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:24.04:LTS
- Versions
- 0.8.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.10
- Versions
- 0.9.8-2
- 0.9.10-2
- 0.9.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-xmldom Ubuntu:26.04:LTS
- Versions
- 0.9.6-1
- 0.9.8-1
- 0.9.8-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/xmldom/xmldom/security/advisories/GHSA-6gmq-8vp8-gcm6
- https://github.com/xmldom/xmldom/pull/1071
- https://github.com/xmldom/xmldom/pull/1072
- https://github.com/xmldom/xmldom/commit/4664386e4f4d99d17b416a151dbe8323e245284b
- https://github.com/xmldom/xmldom/commit/6c3fb5ffeafe7901ec928ce9010988dd716c94a0
- https://github.com/xmldom/xmldom/releases/tag/0.8.15
- https://github.com/xmldom/xmldom/releases/tag/0.9.12
- https://nvd.nist.gov/vuln/detail/CVE-2026-83610