p PatchFirst

CVE-2026-86540

CVE-2026-86540 · knowns before 0.30.0 Arbitrary Code Execution via LSP Binary

This page contains facts from public vulnerability sources. Check the original advisory before updating.

knowns versions before 0.30.0 fail to validate the settings.lsp.languages binary field in project configuration files, allowing attackers to execute arbitrary binaries by crafting a malicious .knowns/config.json file. When a repository with a crafted configuration is opened, the unvalidated binary path is executed twice under the user's account without any verification.

CVSS 8.5 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • knowns

    Versions
    • ≥ 0, < 0.30.0: Affected (semver)
    • 0.30.0: Not affected (semver)

    Update to 0.30.0

  • knowns npm

    Affected ranges
    • SEMVER: < 0.30.0

    Update to 0.30.0

Original sources

Check your server →