CVE-2026-87838
CVE-2026-87838 · Wava Payment 0.3.1 - 0.3.9 - Unauthenticated Merchant Credential Overwrite via Install Webhook
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Wava Payment Plugin WordPress plugin before 0.3.10 does not perform any authorisation, nonce or origin verification on one of its public REST endpoints, allowing unauthenticated attackers to overwrite the stored credential that identifies the merchant account the store's payments are created against, to force the integration into a verified state the site owner never completed, and to remove the payment method from the store's checkout.
CVSS 6.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
wava payment plugin
- Versions
- ≥ 0.3.1, < 0.3.10: Affected (semver)
Update to 0.3.10