p PatchFirst

CVE-2026-8814

CVE-2026-8814

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package exifreader before 4.39.0 are vulnerable to Improper Handling of Highly Compressed Data (Data Amplification) due to decompressing PNG zTXt metadata without enforcing a built-in maximum decompressed output size. When asynchronous parsing is enabled, a crafted PNG file containing a highly compressed zTXt chunk can cause ExifReader to materialize a disproportionately large Comment value in memory.

CVSS 6.9 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • exifreader

    Versions
    • ≥ 0, < 4.39.0: Affected (semver)

    Update to 4.39.0

  • exifreader npm

    Affected ranges
    • SEMVER: ≥ 4.20.0, < 4.39.0

    Update to 4.39.0

Original sources

Check your server →