p PatchFirst

CVE-2026-8933

CVE-2026-8933 · snap-confine Local Privilege Escalation via Capabilities Misconfiguration or Flaw in Execution Environment Setup

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A local privilege escalation vulnerability exists in snap-confine, a set-capabilities core component used internally by Canonical snapd to construct the secure execution environment for snap applications. This vulnerability uniquely affects versions of snap-confine configured with set-capabilities (rather than standard set-uid-root installations). Due to a flaw in how privilege boundaries or security sandboxes are initialized when the binary runs under limited ambient capabilities, a local, unprivileged attacker can exploit this behavior to bypass intended restrictions and execute arbitrary code. Successful exploitation allows the local user to elevate their privileges to full root authority.

CVSS 7.8 · High · EPSS 0.2% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • ubuntu 26.04 lts

    Versions
    • 2.76+ubuntu26.04.3: Not affected (dpkg)

    No fix published

  • ubuntu 24.04 lts

    Versions
    • 2.76+ubuntu24.04.1: Not affected (dpkg)

    No fix published

  • ubuntu 22.04 lts

    Versions
    • 2.76+ubuntu22.04.1: Not affected (dpkg)

    No fix published

  • snapd Debian:13

    Versions
    • 2.68.3-3
    • 2.68.3-3+deb13u1
    • 2.71-1
    • 2.71-2
    • 2.71-3
    • 2.72-1
    • 2.73-3
    • 2.73-4
    • 2.74.1-1
    • 2.75.2-1
    • 2.75.2-2
    • 2.76-1
    • 2.76.3-1
    • 2.76.3-2
    • 2.77.1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • snapd Debian:14

    Versions
    • 2.68.3-3
    • 2.71-1
    • 2.71-2
    • 2.71-3
    • 2.72-1
    • 2.73-3
    • 2.73-4
    • 2.74.1-1
    • 2.75.2-1
    • 2.75.2-2
    • 2.76-1
    Affected ranges
    • ECOSYSTEM: < 2.76.3-1

    Update to 2.76.3-1

  • snapd Ubuntu:22.04:LTS

    Versions
    • 2.53+21.10ubuntu1
    • 2.54.2+22.04ubuntu1
    • 2.54.2+22.04ubuntu2
    • 2.54.2+22.04ubuntu3
    • 2.54.3+git19.g868fc21+22.04
    • 2.54.3+git26.g360067e+22.04
    • 2.55.2+22.04
    • 2.55.2+22.04.1
    • 2.55.3+22.04
    • 2.55.3+22.04ubuntu1
    • 2.55.5+22.04
    • 2.56.2+22.04ubuntu1
    • 2.57.4+22.04
    • 2.57.5+22.04
    • 2.57.5+22.04ubuntu0.1
    • 2.58+22.04
    • 2.58+22.04.1
    • 2.61.3+22.04
    • 2.62+22.04
    • 2.63+22.04
    • 2.63+22.04ubuntu0.1
    • 2.65.3+22.04
    • 2.66.1+22.04
    • 2.67.1+22.04
    • 2.68.5+ubuntu22.04.1
    • 2.71+ubuntu22.04
    • 2.72+ubuntu22.04
    • 2.73+ubuntu22.04
    • 2.73+ubuntu22.04.1
    • 2.74.1+ubuntu22.04.4
    • 2.75.2+ubuntu22.04
    • 2.76+ubuntu22.04
    Affected ranges
    • ECOSYSTEM: < 2.76+ubuntu22.04.1

    Update to 2.76+ubuntu22.04.1

  • snapd Ubuntu:24.04:LTS

    Versions
    • 2.60.4+23.10
    • 2.61.3+24.04
    • 2.62+24.04build1
    • 2.63+24.04
    • 2.63+24.04ubuntu0.1
    • 2.63.1+24.04
    • 2.65.3+24.04
    • 2.66.1+24.04
    • 2.67.1+24.04
    • 2.68.5+ubuntu24.04.1
    • 2.71+ubuntu24.04
    • 2.72+ubuntu24.04
    • 2.73+ubuntu24.04
    • 2.73+ubuntu24.04.1
    • 2.73+ubuntu24.04.2
    • 2.74.1+ubuntu24.04.4
    • 2.75.2+ubuntu24.04
    • 2.76+ubuntu24.04
    Affected ranges
    • ECOSYSTEM: < 2.76+ubuntu24.04.1

    Update to 2.76+ubuntu24.04.1

  • snapd Ubuntu:26.04:LTS

    Versions
    • 2.71.1+ubuntu25.10.1
    • 2.72+ubuntu26.04.1
    • 2.73+ubuntu26.04.1
    • 2.74+ubuntu26.04
    • 2.74.1+ubuntu26.04
    • 2.74.1+ubuntu26.04.3
    • 2.74.1+ubuntu26.04.4
    • 2.75.2+ubuntu26.04.2
    • 2.76+ubuntu26.04.2
    Affected ranges
    • ECOSYSTEM: < 2.76+ubuntu26.04.3

    Update to 2.76+ubuntu26.04.3

Original sources

Check your server →