p PatchFirst

CVE-2026-90442

CVE-2026-90442 · Fireware OS Authenticated Stack Buffer Overflow in certd Allows Denial of Service

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A stack-based buffer overflow vulnerability in the Fireware OS certd process allows an authenticated attacker with access to the Firebox management interface to crash the certificate management service and potentially execute arbitrary code by sending a specially crafted request.

CVSS 8.6 · High · EPSS 0.2% · Fix available

Published
Updated

Affected products and versions

  • fireware os

    Versions
    • ≥ 2025.1, < 2026.4: Affected (custom)
    • ≥ 12.0, < 12.12.4: Affected (custom)

    Update to 12.12.4; Update to 2026.4

  • fireware os

    Versions
    • ≥ 12.0, < 12.5.22: Affected (custom)

    Update to 12.5.22

Original sources

Check your server →