p PatchFirst

CVE-2026-93577

CVE-2026-93577 · Integer Overflow or Wraparound in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to execute arbitrary code on the GitLab server due to an integer overflow issue when compiling a specially crafted regular expression in a CI/CD configuration.

CVSS 9.9 · Critical · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 19.2, < 19.2.7: Affected (semver)
    • ≥ 19.3, < 19.3.3: Affected (semver)
    • ≥ 19.4, < 19.4.1: Affected (semver)

    Update to 19.2.7; Update to 19.3.3; Update to 19.4.1

  • ruby3.1 Debian:12

    Versions
    • 3.1.2-7
    • 3.1.2-7+deb12u1
    • 3.1.2-7+hurd.1
    • 3.1.2-8
    • 3.1.2-8.1~exp1
    • 3.1.2-8.3
    • 3.1.2-8.4
    • 3.1.2-8.5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • ruby3.3 Debian:13

    Versions
    • 3.3.8-2
    • 3.3.8-2.1
    • 3.3.8-2.2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • ruby3.3 Debian:14

    Versions
    • 3.3.8-2
    • 3.3.8-2.1
    • 3.3.8-2.2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →